Някъква идея,защо дизайна се чупи през WP ?!?!?


0
Всичко е валидирано и наред,разделям на хедар,футар,сайдабар,индекс иии край :D:D:D , по-скоро само параграфите са изместени и избутват всичко наляво-надясно :D:D



Отговори



0
Опитай да зададеш на файловете си:
Encoding -> Encode in UTF-8 without BOM
Гледа ли през firebug какво точно се случва?

от georgi.s.yankov (6219 точки)


0
Щом параграфите ти се чупят, най вероятно имаш някой селектор с примерно
div p, или #content p
с които даваш пропъртита на самите параграфи, а worpress си генерира на места разни параграфи или си пуснал някой пост с параграв вътре и като имаш такива селектори и ако не са наприсани подходящо може да се сбъглясат нещата.

от Viktor_Ivanov (2505 точки)


0
Добре най-вероятно проблема е в наследяването и ще трябва,вместо #div p,да слагам класове така ли ?!Пробвах с енкодинга,не стана :(

от F3rrAr1 (-6 точки)


0

Трябва да "пресъздадеш" в WP същия скелет, какъвто е в темата ти на HTML (ако това е невъзможно, трябва да оправиш CSS-a). Пример:

HTML:

...

 

                    <article class="article clear">  
                        <div class="article-title"><h3>Article Title</h3></div>
                        <div class="img-border-2"><img src="images/starcraft2.png"    alt="starcraft logo 1" width="61" height="61"/></div> 
                        <p>
                           Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Nullam urna augue, pulvinar pulvinar, 
                           viverra vel, suscipit. Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Nullam urna 
                           augue, pulvinar pulvinar. Nullam urna augue, pulvinar pulvinar. 
                        </p>
                        <div class="article-separator"></div> 
                    </article>

...
WP:
...

echo "<article class='article clear'>";
echo "<div class='article-title'><h3>";
   the_title();              
echo "</h3></div>";
userfunc_add_image($post);
echo "<p>";                        
   the_content();
echo "</p>";
echo "<div class='article-separator'></div> ";
echo "</article>";
...
И както ти казаха, виж през инспектора на браузера какъв HTML си генерирал ако не знаеш ;)
Успех

от venelinpetrov (1221 точки)


0
Аха ясно , разбрах , мерси много :P

от F3rrAr1 (-6 точки)