WampServer на Windows 10 ?


0
Здравейте, имам проблем със стартирането на сървъра и промяна на портовете му с използването на Wamp Server на Windows 10. Ако някой е запознат с туула и си го ползва за да си стартира цяла директория на сървър нека помогне, понеже изобщо не стартира localhost и издава бъг, мерси.




Отговори



2

И аз откакто смених на 10ка Уамп-а спря да работи. След смяна на конфигурацията на Apache да слуша на портове различни от 80, защото се заемат вече по дефолт от IIS, пак не проработи. По-късно разбрах, че е нужно да се направят промени в host файла в системната директория, като там предстои друга уловка - явно се бекъпва в temp(needs a citation) директорията, и за да промениш нещо реално, е нужно да отвориш двата файла едновременно. 

Ultimately стана много работа за нищо, инсталирах си XAMPP for Windows и всичко потръгна от първия път след като зададох Listen <port> (различен от 80, или останалите използвани от системни сървиси) в config файла. Не забравяй да рестарираш приложението след промяна по файловете.

tl;dr Не използвай WAMP, инсталирай си XAMPP и само му смени порт-а на произволно четирицифрено число.

Успех!


от Pip3r4o (3392 точки)


1

Мерси, ще си дръпна сега и  XAMPP.

Относно подкарването на WAMP намерих едно скрито решение :Д, има един файл httpd.conf във директорията на wamp\bin\apache\apache2.4.9\conf , та навсякъде където по default пише ,че  порта е :80 го replace-ваш с :8000 (примерно) и сега го подкарах . Копирах си цяла директория в папката www/  и  ми се показват на сървъра localhost:8000 както са си по папки локално, само че в браузъра :)


от IvayloAndonov (1994 точки)