"Ctrl + . (dot)" shortcut не работи


0
Здравейте,
Не ми работи клавишната комбинация за ShowSmart опцията - Ctrl+.
Някой има ли идея за причината, както и как да си го оправя?
Предварително благодаря.



Отговори



1

Погледни в тази тема в Stack Overflow. Обсъждан е точно този въпрос. Опитай да си го настроиш от Tools > Environment > Keyboard би трябвало да ти заработи, като активираш, ако е било изключено примерно.


от kalbo_17 (2709 точки)


1
Виж дали нямаш някъде синтактична грешка в кода (по-нагоре или по-надолу). Също така провери дали обекта, върху който се опитваш да извикаш IntelliSence е типизиран (коректен тип, който се разпознава от IDE-то) - може да ти липсва някой using (namespace) или дори референция към библиотека, в която е описан дадения тип, който искаш да ползваш.
Много може да са причините, на мен ми се е случвало дори самото IntelliSence да е изкукало и след рестарт на VisualStudio-то да се оправи.

от cherokee (1277 точки)


1
А така :")
Оказа се че в Tools-Options-General-Keyboard за shortcut не беше избрано Ctrl+.(Global), а някаква комбинация Ctrl+Shift+F12 май с описание HTML5 :D
Другото интересно беше, че при опит да я променя след повторно влизане пак смотания shortcut си беше избран. Е, remove-нах го и сега всичко е наред.
Благодаря за помощта.

от yotov_uktc (416 точки)


2

Иначе ето тук можеш да видиш проверката за включени keyboard shortcuts, както и допълнения за работа с тях, а можеш да разгледаш и техния линк в менюто за цялата гама от използвани клавиши във Pre-defined Keyboard Shortcuts. Ето линка:
http://msdn.microsoft.com/en-us/library/5zwses53(v=vs.110).aspx


от tsonko_genov (708 точки)