html title на маймуница


0

title-ът на PHP страница излиза на маймуница в отворения таб, при това само понякога. Заглавиетo съдържа и текст на латиница, и на кирилица, като само вторият се появява със знаци от сорта на следните:

Като отида на view source обаче, текстът си е на кирилица. Съдържанието е статично, не се взима от базата и енкодингът на файла е utf-8 without BOM. Някой има ли идеи?


в HTML/CSS от Yoana_Nikolova (0 точки)


Отговори



3

Пробвай да сложиш:

<meta charset="utf-8"> 

Преди title тага.

 


от Teodor92 (13062 точки)


0
А моят беше след title тага. :) Благодаря много, изобщо не му бях обърнала внимание!

от Yoana_Nikolova (0 точки)


2
имах случай, когато въпреки, че е сложен, където трябва, всичкия кирилски текст излизаше на каракацили :) Решението на което ме светнаха беше доста странно но работеше: Open with Notepad++ >> Ctrl+A >> Ctrl+C >>Ctrl+N>> Encoding - utf-8 without BOM>> Ctrl+V >>Ctrl+S
PS. Някои може ли да обясни защо енкодинга на notepad-a трябва да е сетнат преди да почнем да пишем?

от antondonev (534 точки)


0
Настроил ли си енкодинга да бъде UTF-8 without BOM за всички документи в Notepad++? При инсталация на Notepad++, всички нови документи се създават с енкодинг ANSI. Аз съм задал в Settings --> Preferences --> New Documents --> Encoding --> UTF-8 without BOM. Другото, ако документа е бил първоначално с енкодинг ANSI или друг, това че си задал не значи нищо. Трябва да convert-неш целия текст в документа от ANSI до UTF-8 without BOM.
EDIT: Решението, което си описал в поста си, реално погледнато сменя енкодинга на UTF-8 without BOM.

от Kovachev (1194 точки)

0
da..............10x

от antondonev (534 точки)